High Frontier Forums

Full Version: Issues with 0.21 on Ubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I tried out 0.20, and now 0.21, on Ubuntu and found a few new issues with 0.21.

First, there are the menu buttons. When the mouse moves over them, it looks like static shows up for a frame. After doing this a few times, I think the texture has white text with odd coordinates that scale it in odd ways. Not a big deal, but it didn't happen with 0.20.

Next, full-screen is no longer usable. When selected, it does result in a full-screen display, but it looks like the menu animates moving somewhere up and to the right off screen resulting in a black window with no user interface. It still responds to alt-f4, but that seems to be the only option.

Finally, the zones in the colony now render to make the different densities indistinguishable. They are all solid, which looks like high density from 0.20. In 0.20, low and medium density were indistinguishable from each other, but easily distinguished from high.

I've also caught some people walking on the grass parallel to the walkways. Shame on them.
Hmm. Thank you very much for the bug reports!

People walking on the grass isn't necessarily a bug — they will do that briefly while going to/from a building. But if they're really walking parallel to the walkway for an extended distance, then yeah, that does sound like a bug.

I'm really baffled by the full-screen and menu glitches, because I can't think of any changes we made to that stuff between 0.20 and 0.21. Perhaps it would help to see it — can you post some screen shots?

As for the zone rendering, we did run into a problem that sounds like what you describe, when using the latest version of Unity. Something changed in how it compiles shaders, and we were seeing an effect like that. But we fixed it (a simple change from a float to an int in the zone shader), at least on Mac. It's frustrating but reasonably likely that it behaves differently on Linux (or possibly depending on video card, drivers, etc.). A screen shot there would help us determine how similar this is to the problem we saw.

We really want to get these problems ironed out — thanks for your help and patience as we do so!

- Joe
The people walking parallel to the walkway didn't seem to be going directly to a building. I didn't find one while making screen shots, but didn't look too hard. Maybe I'll find one tomorrow when I'm not chasing bugs in my own software :-)

The full screen and menu bugs did seem rather odd to me as well since you haven't mentioned working on those and they do work on 0.20. I don't have a screen shot of the full screen bug since it moves the menu very fast and then the whole screen is black save for the mouse cursor; there isn't much to look at. I did get one of the static-like stuff on a menu button (first image). I also got images of the zones in 0.20 (second) and 0.21 (last) using the same spot of the same colony. I don't know if both low and medium density is in that area since I forgot and they look the same on both versions. I should have shown the area just above; in the 0.20 shot at the top is a high density region right next to a walkway. It is solid, just like all the zones in 0.21.

In case it is important, the computer has an Intel i5-5200 processor and uses that for graphics, too. I would have guessed that the hardware has more to do with shader incompatibilities, but I haven't written any lately, only did some simple stuff, and never attempted to make any run across platforms.

Hope this helps!
Thank you, Jeff.  That is very much appreciated.  I've created tickets in our issue tracker (here and here) and we'll do our best to get them resolved for the next release.

(The next release is not likely to take anywhere near as long as the last one — those little people were a lot of work!)

I might also try throwing up a little WebGL test app or two, which could let us much more quickly check visual issues on different machines without having to download anything (except perhaps a WebGL-compatible browser).
OK, can I trouble you to try out the little test app at http://highfrontier.com/quicktest/index.html ?

The result should look like the attached image.

[attachment=5]

...but I'm rather hoping that on your machine, it doesn't — this uses exactly the same code as High Frontier 0.21, so it ought to show the same visual glitches.  But now that it's isolated in a trivial app and with an easy way to test, I can (hopefully) dig in and solve it.

So, please try it when you get a chance, and let me know what you see!

Thanks,
- Joe
I gave it a try with Firefox 44. What it rendered looks just like your image. The buttons are responding to the mouse, and without the staticy looking texture.
Well, nuts. The button thing doesn't bother me too much — I've heard from a Unity rep that this is a recently-introduced bug, fixed in the next patch. So that one should go away all on its own, and perhaps it's just inconsistent enough not to show up in the simple test case.

But I was really hoping the shader would show the same problem as in HF0.21. It's the exact same shader, and you're running it on the same machine... it's WebGL instead of stand-alone, but I haven't seen anything suggesting that that should matter.

Just to be certain: are you sure you had some medium- and low-density zones there in your game? The previous (buggy) shader probably drew more or less random hatching, regardless of the actual density. So it might have been easy to get confused about what zone density you had. I don't suppose there's any chance we're seeing high-density zones because they are, in fact, all high density?

(I highly doubt that, since I would expect to see some cross-hatching at the edges, but I have to ask!)
Same computer, no changes to hardware or software. At least the problem is consistent.

Both images of the colony interior shows low and/or medium density zones. Maybe I just can't tell the difference with random hatching, but high density shows solid on both versions. I should have gotten better screen shots to show that.

Anything else I can try to help?
Thanks, you've been very helpful.  I'm a bit stumped as to why the zone shader should work in the simple WebGL test app, but not in the desktop app.  If you're willing, I think I'll take this to email — I may need to send you a desktop build of the minimal test app.  (And if that still doesn't show the problem, then I'm really baffled!)